| プレビュー:このページの安全上の注意は、まだネイティブの校閲を受けていません。 |
機械、メニュー、パネルのボタン、エディタは、すべてキーボードで操作できます。3Dビューの回転とズーム、3Dビュー内の点の選択、パネルのサイズ変更にはマウスが必要です。Windows では、スクリーンリーダーがパネルのボタンと表示値を読み上げます。
ヘルプ > キーボードショートカット(または ?)に、Studio のすべてのキーが一覧されます。
| キー | 動作 |
|---|---|
| F1 | 非常停止:押して作動、もう一度押して解除 |
| F2 | 電源投入 |
| F3 | 原点復帰 |
| F4 | ロック解除 |
| F5 | サイクルスタート |
| F6 または Space | フィードホールド |
| F7 | 停止:フィードホールドし、機械が止まったらリセット。もう一度押すと、すぐにリセット |
| F8 | 冷却 のオン・オフ |
| F9 | 主軸正転 |
| F10 | 主軸逆転 |
| F11 | 主軸停止 |
| F12 または Ctrl+X | リセット |
ジョグとハンドル:
| キー | 動作 |
|---|---|
| ← → | X をジョグ |
| ↓ ↑ | Y をジョグ |
| Page Down、Page Up | Z をジョグ |
| Shift とこれらのいずれか | キーを押している間ジョグ |
| 1–5 | ステップを 0.01、0.1、1、10、50 mm のいずれかにする |
| 6 | 押している間ジョグ:すべてのジョグキーが、押している間ジョグする |
| Ctrl+1〜Ctrl+4 | ジョグ速度を 100、300、1500、3000 mm/min のいずれかにする |
| Esc | ジョグ停止 |
| X、Y、Z | ハンドルの軸を選ぶ |
| , と . | ハンドルを 1クリック分下げる、または上げる(Shift で 10クリック分) |
オーバーライド:
| キー | 動作 |
|---|---|
| Ctrl+↑、Ctrl+↓ | 送り +10 %、−10 % |
| Ctrl+→、Ctrl+← | 主軸 +10 %、−10 % |
| Ctrl+0 | 送りと主軸を 100 % に戻す |
ジョグキーを 1回押すごとに、1ステップ動きます。押し続けるジョグは、キーを離すか、ウィンドウがフォーカスを失うと止まります。インチでは、ステップは 0.0005〜2 in、速度は 4〜120 in/min です。
F キーは、どこにいても使えます。ほかの機械のキーは、テキストボックス、リスト、エディタに入力している間は働きません。3Dビューをクリックすると、キーの操作が機械に戻ります。
数字キー、および , と . のキーは、キーボード上の位置で働くため、どのキー配列でも使えます。
F1 を押すか、機械バーの右端にある丸い赤いボタンをクリックします。ツインでは、機械のボタンと同じように、非常停止回路が開きます。軸のドライバと主軸インバータの電源が切れ、コントローラが ALARM:10 を発生させます。もう一度 F1 を押すと解除されます。その後、手順に従って作業に戻ります:電源投入、リセット、原点復帰。
|
| キー | 動作 |
|---|---|
| Alt+1〜Alt+6 | 準備、CAM、プログラム、実行、分析、診断 のいずれかへ移動 |
| Ctrl+Tab、Ctrl+Shift+Tab | 次または前のワークスペース |
| Ctrl+J | ドックを折りたたむ、または展開する |
| Ctrl+Shift+M | 機械を切り替える |
| Ctrl+O | プログラムを開く… |
| Ctrl+P | プログラムを印刷… |
| Ctrl+, | 設定… |
| Ctrl+L | 監査ログ… |
| Ctrl+Q | 終了 |
| ? または / | キーボードショートカット |
| Alt とメニューの文字 | そのメニューを開く。Alt だけを押すと、メニュー名が強調表示される |
| Tab、Shift+Tab | パネルのボタン間を移動する。Space で、枠の付いたボタンを押す |
| Esc | ポップアップまたはサブウィンドウを閉じる |
|
プログラム ワークスペースのエディタには、専用のキーがあります。
| キー | 動作 |
|---|---|
| Ctrl+E | エディタに移動し、機械に戻る |
| Ctrl+K | 読み込んで検査 |
| Ctrl+S | バージョン保存 |
| Ctrl+Shift+S | プログラムをファイルとして保存 |
| Ctrl+D | 保存したバージョンとの 比較 |
| Ctrl+F、Ctrl+G、Ctrl+H | 検索、行へ移動、置換 |
| Ctrl+B | その行の ブレークポイント |
| Ctrl+Shift+B | 条件で一時停止 |
| Ctrl+. | その行に対する検査の提案を適用 |
| Alt+↓、Alt+↑ | 次または前の検出事項、または差分 |
| Shift+F10 またはメニューキー | その行のメニュー |
| Ctrl+Shift+O | 最適化 |
| Ctrl+Shift+G | 生成… |
| Ctrl+Shift+R | 機械にあるプログラムを取り込む |
| Esc | 比較を閉じる |
マニュアルのウィンドウでは、Ctrl+F で検索、Alt+← と Alt+→ で戻る・進む、Esc で閉じます。
準備 でワークを配置している間は、矢印キーで移動し(Shift で細かく、Ctrl で粗く)、Q と E で回転し、Enter で配置し、Esc で元に戻します。
ヘルプ > キーボードショートカット には、上記のすべてのキーが 1つの一覧で表示されます。次のコマンドにはキーがありません。それぞれのメニューを使ってください。
Windows では、Studio は、システムのアクセシビリティインターフェースを通じてスクリーンリーダーと連携します。Studio の各パネルで、スクリーンリーダーは次の情報を受け取ります。
フォーカスがどこにあっても、次の 2つは、発生した時点で通知されます。アラーム(次の手順を含む)と、AI による機械の変更の要求です。
マニュアルのウィンドウでは、ページのテキストが、見出しとリンクを含めてスクリーンリーダーに渡されます。
1.0 では次のとおりです。
3Dビュー自体は、スクリーンリーダーに何も渡しません。3Dビューに表示される数値は、右の列と機械バーにあり、そちらはスクリーンリーダーが読み上げます。ワークの点をクリックすると、ビューの下の文(プログラムの行と位置)が読み上げられます。
Studio は、Windows で画面ごとに設定した表示スケールに従います。Studio 独自の文字サイズ設定はありません。
表示 > 外観 > 工場モード(大) を選ぶと、機械バー、そのボタン、非常停止、文字、プログラムリスト、位置表示が大きくなり、実行 ワークスペースには、腕を伸ばした距離から読むためのレイアウトが適用されます(ライト、ダーク、工場モードを参照)。
システムのアニメーションがオフになっている場合、3Dビューは、滑らかに移動する代わりに、新しいビューへ瞬時に切り替わります。