ウィンドウとワークスペース

Studio のウィンドウは、上部にメニューとトップバー、中央に 6つのワークスペース、下部に機械バーがあります。ワークスペースはそれぞれ、1つの主な作業を受け持ちます。機械バーには、どのワークスペースでも、機械の状態と次の手順が表示されます。

ウィンドウの各部

上から順に:

Studio にステータスバーはありません。その役目は機械バーが果たします。

タイトル行とメニュー

メニューは次のとおりです:ファイル、編集、表示、機械、プログラム、シミュレーション、AI、ツール、ヘルプ。

メニューを開いている間は、どのキーも機械に届きません。メニューには、お使いのユーザーレベルの項目だけが表示されます(ユーザーレベルを参照)。

トップバー

左から右へ:

機械バー

機械バーはウィンドウの下端に沿って伸びています。左から右へ:

  1. 状態:アイドル、実行中、ジョグ、原点復帰中、ホールド、扉、工具交換、チェックモード、スリープ、アラーム、非常停止、電源オフ のいずれかです。
  2. プログラム:名前、実行中の行、いまいるセクション、進捗バー、経過時間と残り時間。プログラムがない場合は、プログラムが読み込まれていません、機械が原点復帰済みかどうか、工具、ワーク座標オフセットを表示します。
  3. 次の手順:緑の アラームなし、または 次の手順: とそれを実行するキー。アラーム中は、アラーム、次の手順、すべての手順 を表示します。すべての手順 は、作業に戻るまでの手順を並べたものです(アラームと対処を参照)。
  4. 時計:シミュレーションの時刻、その倍速、実際に出ている速度。砂時計のキーでシミュレーションを一時停止します。
  5. キー:シングルブロック、サイクルスタート(F5)、フィードホールド(F6)、停止(F7)。Studio が示すキーは塗りつぶされ、いま使えないキーは薄く表示されます。
  6. 非常停止(F1):右端の丸い赤いキー。

ウィンドウが狭いと、バーは次の順に表示を省きます。まず時計の時刻、次にプログラムのセクションと時間(ツールチップに移ります)、次に時計の速度、最後に次の手順の文言です。

3Dビュー

3Dビューには、機械、ワーク、工具の現在の様子が表示されます。

同じ選択肢は 表示 > 3Dビュー にもあります。表示 > 色分け は、軌跡とワークを、送り速度、切削抵抗、切りくず厚さ、びびり指標、プログラムの行のいずれかで色分けします(エンジニアレベル以上)。

ドック

ドックは 3Dビューの下にあります。タブはワークスペースによって異なります:

ワークスペースタブ
実行プログラム、グラフ、コンソール、メッセージ、AIアクティビティ
準備測定結果(部品を測定した後)、工具テーブル
CAM検査結果、AIアクティビティ、バージョン、プログラムプレビュー
プログラムコンソール

分析、診断、工場モードにはドックがありません。

Ctrl+J を押すか、タブの右端の矢印をクリックすると、ドックがタブの行だけの状態に折りたたまれます。

6つのワークスペース

ワークスペースは、トップバーのタブ、Alt+1 から Alt+6、Ctrl+Tab と Ctrl+Shift+Tab、または 表示 メニューで切り替えます。CAM または プログラム で サイクルスタート を押すと、実行 に移ります。プログラムの実行中は、実行 タブに緑の点が付きます。

準備

準備(Alt+1)は、機械と部品を 1ステップずつ整えます。ステップは 電源、原点復帰、段取り、工具、原点、プログラム、加工 の順です。右のパネルは、ステップを自分で選ぶまで次の手順に追従します。ジョブの段取りを参照してください。機械、電源、原点復帰については、機械と電源を参照してください。

CAM

CAM(Alt+2)はプログラムを作ります。左にジョブの段取り、形状、加工工程、右に選択した項目の入力欄、下に プログラム生成 があります。プログラムの作成を参照してください。エンジニアレベル以上です。

プログラム

プログラム(Alt+3)には、プログラムとサンプル部品、エディタ、プログラムのチェック結果を含むプレビューがあります。プログラムとエディタを参照してください。

実行

実行(Alt+4)は、読み込んだプログラムを実行します。右の列には、位置、主軸と送り、オーバーライド、切削、操作盤のキー、手動操作、工具とゼロ位置が表示されます。プログラムの実行と再開を参照してください。

分析

分析(Alt+5)は、実行を振り返ります。そのグラフ、各行の時間と力、安定限界線図です。エンジニアレベル以上です。分析と診断を参照してください。

診断

診断(Alt+6)には、機械の電源系統、コントローラの入力、ドライバが表示され、ツインに故障を注入できます。テクニシャンレベル以上です。分析と診断を参照してください。

メッセージと次にすること

Studio は、何が起きたか、次に何をすればよいかを、次の場所で伝えます:

機械 > 次の手順を実行 は、機械バーが示す手順を実行します。その手順だけです。アラームでプログラムが止まった場合、手順の最後に、やり直しを始めるブロックが示されます(ブロックからの再開を参照)。

ユーザーレベル

ユーザーレベルは、その段階で必要なものを表示し、それ以外を隠します。レベルは 5つあります:

レベル追加されるもの
デモサンプル部品のある 実行 ワークスペース。プログラム タブと メッセージ タブ
オペレータ準備 と プログラム。オーバーライド、操作盤、手動操作、工具とゼロ位置。機械 のサブメニュー。コンソール、工具テーブル、AIアクティビティ。設定、監査ログ、AI メニュー。機械の切り替え
テクニシャン診断。ワークの配置の調整。工場出荷時にリセット…
エンジニアCAM と 分析。切削の測定値、グラフ、色分け、グラフの書き出し、比較する部品
研究者診断 の モデルとデータ カード

各レベルには、表でそれより上にあるレベルのすべてが含まれます。新規インストールは エンジニア で始まります。

レベルを変更するには、ツール > UIレベル、トップバーのレベル、または ツール > 設定… > 全般 を使います。

補足

レベルは、教えるときや学ぶときのために、ウィンドウの表示を整えるものです。何もロックしません。機械のキーは、どのレベルでも使えます。

ライト、ダーク、工場モード

表示 > 外観 で、システムに合わせる、ライト、ダーク のいずれかを選び、工場モード(大) のオンとオフを切り替えます。2つの選択は独立しています。工場モードは、どちらの外観でも使えます。

Studio 自身のパネルは、すぐに切り替わります。システムが描画するリストとテキストボックスは、次回の起動時に新しい外観になります。

工場モードは、機械のそばで、腕を伸ばした距離から操作するためのものです:

パネルとそのサイズ

2つのパネルの境界をドラッグするとサイズを変更できます。境界をダブルクリックすると、設計どおりのサイズに戻ります。3Dビューは、表示倍率 100 % で少なくとも 360 × 240 ピクセルを保ちます。パネルの境界を動かせるのはマウスだけです。表示 > レイアウトを元に戻す で、すべてのワークスペースのパネルを一度に設計時の大きさに戻します。

Studio は、機械ごとに、パネルのサイズ、ドックのタブと折りたたみの有無、最後にいたワークスペースを記憶します。次回の起動のために、ウィンドウの位置とサイズも記憶します。