Dies ist das Handbuch zu Studio 1.1.0, einer früheren Version. Das Handbuch der neuesten Version

Dokumentation 1.1.0 Benutzerhandbuch

Vorschau: Die Sicherheitshinweise dieser Seite sind noch nicht muttersprachlich geprüft.

Ein Programm ausführen und fortsetzen

Der Arbeitsbereich Ausführen führt das geladene Programm aus und zeigt, was die Maschine tut, während sie schneidet. Wenn ein Lauf stoppt, nennt Studio den nächsten Schritt und kann das Programm ab einem Satz erneut starten.

Laden und Starten

Um ein Programm in die Maschine zu laden, gehen Sie auf eine dieser Arten vor:

  • Datei > Programm öffnen… (Strg+O): Wählen Sie eine G-Code-Datei. Studio liest sie; es schreibt nie in Ihre Datei.
  • Datei > Beispielteile…: Wählen Sie ein Beispiel. Studio richtet dafür auch das Rohteil, die Werkzeuge und den Werkstücknullpunkt ein.
  • Im Arbeitsbereich Programm lädt Laden und prüfen (Strg+K) das Programm im Editor.

Die Maschinenleiste zeigt dann den Namen des Programms, die Anzahl seiner Sätze und etwa, wie lange es dauert.

Zum Starten klicken Sie in der Maschinenleiste auf Zyklusstart (F5). Zyklusstart ist farbig gefüllt, wenn das Programm geladen ist und die Maschine im Leerlauf und referenziert ist. Hat die Programmprüfung Probleme gefunden, sagt die Konsole das beim Start des Programms.

Bevor Sie ein Programm auf einer echten Maschine ausführen, prüfen Sie es: Programm > Programm prüfen schickt es durch den Prüfmodus der Steuerung. Die Steuerung liest jeden Satz, und die Maschine bewegt sich nicht.

Einen Lauf beobachten

Während ein Programm läuft:

  • Die 3D-Ansicht zeigt das Werkzeug, die Spur seiner Spitze und das Werkstück, wie es geschnitten wird. Werkzeug-Nahansicht zeigt das Werkzeug im Eingriff.
  • Der Reiter Programm im Dock zeigt die Programmliste: Der ausgeführte Satz ist markiert, erledigte Sätze sind heller, und ein Balken zeigt die Zeit jedes Satzes. Aktuellem Satz folgen hält den Satz im Blick.
  • Programmstruktur neben der Programmliste teilt das Programm in seine Abschnitte und Ebenen (aus den Kommentaren des Programms) mit ihren Zeiten auf.
  • Die rechte Spalte zeigt die Anzeigen.

Wenn das Programm endet, sagt der Reiter Meldungen, wie viele Sätze gelaufen sind und wie lange der Lauf in der Simulation gedauert hat.

Fortschritt und verbleibende Zeit

Die Maschinenleiste zeigt den ausgeführten Satz von allen Sätzen, den Anteil der erledigten Sätze sowie Lauf und Rest:

  • Lauf ist die bisherige Maschinenzeit, in der Zeit der Simulation;
  • Rest ist die Schätzung für die verbleibende Zeit, aus den Vorschüben und Eilgängen des Programms.

Nach einem Alarm zeigt die Leiste den Satz, bei dem das Programm angehalten hat.

Die Anzeigen

Die rechte Spalte von Ausführen, von oben:

  • Position: jede Achse in Werkstück- und Maschinenkoordinaten, mit einer Markierung, wenn die Achse referenziert ist. Darunter die Zeile der modalen Codes: die geltenden G-Codes, das Werkzeug, der Vorschub, die Spindeldrehzahl und die M-Codes. Bei einem Alarm zeigen die Spindel und das Kühlmittel den Zustand, den die Maschine hat, und die Werte des Programms stehen im Tooltip;
  • Spindel und Vorschub: die Spindeldrehzahl (der Bogen ist die Drehzahl, die Marke die Solldrehzahl), die Last der Spindel (grün bis 80 %, rot über 100 %) und der Vorschub;
  • Schnitt (ab Stufe Ingenieur): die Schätzungen des Zwillings für die Schnittkraft, die Leistung, den Ratterkennwert und den Vorschub pro Zahn;
  • Overrides, Bedienfeld, Handbetrieb und Werkzeuge und Nullpunkt (ab Stufe Bediener).

Klicken Sie auf den Titel eines Abschnitts, um ihn einzuklappen. Im Werkstattmodus zeigt Position zusätzlich Restweg: den Weg, der im aktuellen Satz noch bleibt, für jede Achse.

Vorschub halt, Stopp und Overrides

  • Vorschub halt (F6 oder Leertaste) bremst die Achsen bis zum Stillstand ab; die Spindel dreht weiter. Zyklusstart setzt das Programm fort.
  • Stopp (F7) hält zuerst an und setzt die Steuerung zurück, sobald die Maschine steht. Drücken Sie ihn erneut, um sofort zurückzusetzen.
  • Reset (F12) stoppt das Programm sofort.

Die Overrides ändern den Vorschub und die Spindeldrehzahl des Programms, während es läuft, von 10 % bis 200 %:

OverrideTastenAuf dem Bildschirm
VorschubStrg+↑, Strg+↓: ±10 %Overrides: Regler ziehen; mit Strg in Schritten von 1 %
DrehzahlStrg+→, Strg+←: ±10 %Overrides: Regler ziehen
EilgangMaschine > Overrides: 25 %, 50 %, 100 %Overrides: 100, 50, 25

Strg+0 oder ein Doppelklick auf einen Regler setzt den Vorschub und die Drehzahl auf 100 % zurück.

Einzelsatz

Einzelsatz in der Maschinenleiste hält das Programm nach jedem Satz an. Klicken Sie auf Zyklusstart oder wählen Sie Programm > Nächster Satz, um den nächsten Satz auszuführen. Sie können ihn vor dem Start oder während des Laufs aktivieren; klicken Sie erneut darauf, um ohne Halt weiterzulaufen.

Tippbetrieb und Handrad

Den Tippbetrieb nutzen Sie in Ausführen unter Handbetrieb (der Abschnitt ist zunächst eingeklappt) oder mit den Tasten (siehe Die Tasten für die Maschine).

  • Schrittweite: 0,01; 0,1; 1; 10 oder 50 mm pro Tastendruck oder Gedrückt halten: Die Achse fährt, solange Sie die Taste halten.
  • Geschwindigkeit: 100, 300, 1500 oder 3000 mm/min.
  • Das Tastenfeld: X und Y im Kreuz, Z daneben, Tippen stoppen (Esc) in der Mitte.
  • Handrad: Wählen Sie X, Y oder Z und das Inkrement (×1, ×10, ×100: 0,001; 0,01 oder 0,1 mm pro Raste), und ziehen Sie dann die Drehscheibe oder drehen Sie das Mausrad darüber.

Der Tippbetrieb ist nur möglich, wenn die Maschine eingeschaltet ist, im Leerlauf steht, keinen Alarm hat und kein Programm läuft. Eine gehaltene Tippbewegung stoppt, wenn Sie die Taste loslassen oder das Fenster den Fokus verliert.

Extras > Einstellungen… > Bedienfeld und Geräte > Handrad legt fest, wie sich das Handrad verhält: Geschwindigkeit stoppt die Achse, wenn das Rad stehen bleibt; Weg fährt jede Raste.

Alarme und was zu tun ist

Bei einem Alarm wird der Zustand in der Maschinenleiste rot, und die Leiste zeigt:

  • den Alarm und was er bedeutet, zum Beispiel ALARM:17 Ein Motorantrieb meldet einen Fehler;
  • Nächster Schritt: was jetzt zu tun ist, mit der Taste, die es ausführt;
  • Alle Schritte, wenn es mehr als einen gibt.

Klicken Sie auf die Taste oder verwenden Sie Maschine > Nächsten Schritt ausführen, um den nächsten Schritt auszuführen. Nach jedem Schritt ermittelt Studio die Schritte neu aus dem Zustand der Maschine.

Die weiteren Anzeichen eines Alarms: eine Zeile unter Position, wenn man der Position nicht mehr trauen kann, der rote Satz in der Programmliste, an dem das Programm angehalten hat, und eine Beschriftung am Antrieb in der 3D-Ansicht.

Die Alarme, ihre Ursachen und was sie beseitigt: Alarme.

Die Schritte zurück in den Betrieb

Alle Schritte öffnet die Schritte zurück in den Betrieb: die Ursache, dann die Schritte der Reihe nach, jeden mit seiner Taste und dem Grund, warum er nötig ist. Der Schritt, der jetzt dran ist, ist markiert. Ein Klick führt nur den nächsten Schritt aus.

Zum Beispiel nach einem Antriebsalarm (ALARM:17):

  1. Not-Halt drücken, Antriebe stromlos schalten (F1): Der Alarm eines Antriebs erlischt nur, wenn der Antrieb stromlos wird.
  2. Not-Halt entriegeln (F1).
  3. Einschalten (F2): Die Antriebe haben wieder Spannung.
  4. Reset (F12): Die Steuerung behält ALARM:17, nachdem sich die Antriebe erholt haben.
  5. Referenzfahrt (F3): Die Spannung war aus, daher ist der Position nicht zu trauen.

Wurde der Fehler in Diagnose injiziert, sagt die Ursache das, mit der Uhrzeit.

Hat ein Alarm ein Programm gestoppt, enden die Schritte mit dem Satz, ab dem neu gestartet wird, zum Beispiel dem Anfang der Ebene, in der es gestoppt hat.

Ab einem Satz neu starten

Studio kann ein Programm ab jedem Satz starten. Es schreibt einen Startabschnitt, der die Maschine so einrichtet, wie das Programm sie an diesem Satz hätte, und führt dann den Rest aus.

  1. Stoppen Sie das Programm. Die Maschine muss eingeschaltet sein, und es darf kein Programm laufen.
  2. Klicken Sie im Reiter Programm des Docks mit der rechten Maustaste auf den Satz und wählen Sie Ab Satz … starten, dann OK. Im Editor klicken Sie mit der rechten Maustaste auf den Rand des Satzes oder drücken Umschalt+F10. Ergebnis: Studio lädt „Name (ab Satz n)“, startet es aber nicht.
  3. Klicken Sie auf Zyklusstart.

Der Startabschnitt führt folgende Schritte aus:

  1. Z ganz nach oben fahren;
  2. die Einheiten, die Ebene, den Distanzmodus und die Nullpunktverschiebung setzen, die das Programm an diesem Satz hatte;
  3. das Werkzeug wechseln, wenn das Programm es vor diesem Satz gewechselt hatte;
  4. das Kühlmittel und die Spindel mit der Drehzahl des Programms einschalten und warten, bis die Spindel ihre Drehzahl erreicht hat;
  5. in sicherer Höhe über den Startpunkt fahren, bis 2 mm darüber absenken und dann mit Vorschub nach unten fahren;
  6. das Programm ab diesem Satz fortsetzen.

Die Vorschauprüfung prüft dann den Rest gegen das Werkstück, wie es jetzt ist.

Achtung

Studio kann manche Sätze vor dem Start nicht nachvollziehen: Parameter, Ausdrücke, Unterprogramme, G10, G28, G30 und G92. Die Hinweise beim Laden listen sie auf. Prüfen Sie den Zustand der Maschine, bevor Sie Zyklusstart drücken.

Den Start zuerst an einer Kopie ausprobieren

Nachdem ein Alarm ein Programm gestoppt hat, enden die Schritte mit Vorschau Startabschnitt…. Das öffnet den Startabschnitt und seine Hinweise.

  1. Klicken Sie auf Auf einer Kopie testen. Ergebnis: Der Start läuft auf einer verborgenen Kopie der Maschine, ausgehend vom Werkstück, wie es jetzt ist, und Studio meldet seine Zeit, jede Kollision, den höchsten Ratterkennwert und wie viel Material er abgetragen hat.
  2. Wenn es richtig aussieht, folgen Sie den Schritten zurück in den Betrieb und starten Sie dann ab dem Satz.

Ausführen mit der Simulationsgeschwindigkeit

Der Zwilling läuft in Echtzeit. Simulation > Geschwindigkeit lässt ihn mit ×0,5 bis ×50 der Echtzeit laufen. Die Uhr in der Maschinenleiste zeigt die Zeit der Simulation, die gewählte Geschwindigkeit und die Geschwindigkeit, die der Computer erreicht.

Simulation > Simulation pausieren oder die Sanduhr in der Maschinenleiste hält die Zeit des Zwillings an: Solange sie steht, ändert sich nichts. Zyklusstart setzt fort. Haltepunkte und Pausenbedingungen im Editor halten die Zeit des Zwillings auf dieselbe Weise an (siehe Programme und der Editor).

Das Pausieren der Simulation ist kein Vorschub halt: Der Zustand der Maschine ist eingefroren, nicht angehalten.