これは以前のバージョン、Studio 1.1.0 のマニュアルです。 最新バージョンのマニュアル

ドキュメント 1.1.0 ユーザーマニュアル

プレビュー:このページの安全上の注意は、まだネイティブの校閲を受けていません。

プログラムの実行と再開

実行 ワークスペースは、読み込まれたプログラムを実行し、加工中の機械の動きを表示します。実行が止まると、Studio は次の手順を案内し、プログラムをあるブロックから再び開始することもできます。

読み込みと開始

プログラムを機械に読み込むには、次のいずれかを行います。

  • ファイル > プログラムを開く…(Ctrl+O):G コード ファイルを選びます。Studio はファイルを読み取るだけで、書き込むことはありません。
  • ファイル > サンプル部品…:サンプルを選びます。Studio は、そのサンプル用の素材、工具、ワーク原点も段取りします。
  • プログラム ワークスペースで 読み込んで検査(Ctrl+K)を押すと、エディタのプログラムが読み込まれます。

機械バーには、プログラム名、ブロック数、おおよその所要時間が表示されます。

開始するには、機械バーの サイクルスタート(F5)を押します。サイクルスタート は、プログラムが読み込まれ、機械がアイドル状態で原点復帰済みのときに、塗りつぶし表示になります。プログラム検査で問題が見つかっていた場合は、プログラムの開始時にコンソールがそのことを知らせます。

実機でプログラムを実行する前に、検査してください。プログラム > プログラムを検査 は、プログラムをコントローラのチェックモードに通します。コントローラはすべてのブロックを読み取り、機械は動きません。

実行を見守る

プログラムの実行中は、次のように表示されます。

  • 3Dビューに、工具、工具先端の軌跡、切削されていくワークが表示されます。工具の拡大表示 では、切削中の工具を拡大して見られます。
  • ドックの プログラム タブにリストが表示されます。実行中のブロックにはマークが付き、完了したブロックは薄く表示され、バーで各ブロックの時間がわかります。実行中のブロックに追従 を使うと、そのブロックが常に表示範囲に入ります。
  • リストの横にある プログラム構造 は、プログラムを(プログラム中のコメントに基づいて)セクションとレイヤーに分け、それぞれの時間を表示します。
  • 右の列には、表示値が並びます。

プログラムが終わると、メッセージ タブに、実行されたブロック数と、シミュレーション内で実行にかかった時間が表示されます。

進捗と残り時間

機械バーには、全ブロック中の実行中のブロック、完了したブロックの割合、経過 と 残り が表示されます。

  • 経過 は、これまでの機械時間で、シミュレーションの時間で表されます。
  • 残り は、残りの部分の推定値で、プログラムの送りと早送りから求めます。

アラームの後は、バーにプログラムが停止したブロックが表示されます。

表示値

実行 の右の列には、上から順に次の項目があります。

  • 位置:各軸のワーク座標と機械座標。軸が原点復帰済みであれば、印が付きます。その下にモーダル行があり、有効な G コード、工具、送り、主軸回転数、M コードが表示されます。アラーム中は、主軸とクーラントが機械の実際の状態で表示され、プログラムの値はツールチップに表示されます。
  • 主軸と送り:主軸回転数(円弧が実際の回転数、マークが指令された回転数)、主軸負荷(80 % までは緑、100 % を超えると赤)、送り。
  • 切削(エンジニアレベル以上):ツインによる推定値。切削抵抗、パワー、びびり指標、1刃当たりの送り。
  • オーバーライド、操作盤、手動操作、工具と原点(オペレータレベル以上)。

セクションのタイトルをクリックすると、折りたたまれます。工場モードでは、位置 に 残移動量 も表示されます。これは、各軸について、現在のブロックの残りの距離です。

フィードホールド、停止、オーバーライド

  • フィードホールド(F6 または Space)は、軸を減速して停止させます。主軸は回り続けます。サイクルスタート で続行します。
  • 停止(F7)は、まず送りを保持し、機械が止まってからコントローラをリセットします。もう一度押すと、すぐにリセットします。
  • リセット(F12)は、プログラムをすぐに停止します。

オーバーライドは、実行中のプログラムの送りと主軸回転数を、10 % から 200 % の範囲で変更します。

オーバーライドキー画面上の操作
送りCtrl+↑、Ctrl+↓:±10 %オーバーライド:ノブをドラッグ。Ctrl を押しながらで 1 % 刻み
主軸Ctrl+→、Ctrl+←:±10 %オーバーライド:ノブをドラッグ
早送り機械 > オーバーライド:25 %、50 %、100 %オーバーライド:100、50、25

Ctrl+0、またはノブのダブルクリックで、送りと主軸が 100 % に戻ります。

シングルブロック

機械バーの シングルブロック は、1ブロックごとにプログラムを停止します。サイクルスタート、または プログラム > 次のブロック を押すと、次のブロックを実行します。開始前でも実行中でもオンにできます。もう一度クリックすると、停止せずに続行します。

ジョグとハンドル

ジョグは、実行 の 手動操作(最初は折りたたまれています)で行うか、キーで行います(機械のキーを参照)。

  • 移動量:1回押すごとに 0.01、0.1、1、10、または 50 mm。または 押している間ジョグ:キーを押している間、軸が動きます。
  • 速度:100、300、1500、または 3000 mm/min。
  • パッド:X と Y を十字に、Z をその横に配置し、中央に ジョグ停止(Esc)があります。
  • ハンドル:X、Y、Z のいずれかと刻み(×1、×10、×100:1目盛りあたり 0.001、0.01、0.1 mm)を選び、ダイヤルをドラッグするか、その上でマウスホイールを回します。

ジョグできるのは、機械の電源が入っていて、アイドル状態で、アラームが出ておらず、プログラムが実行されていないときだけです。押し続けているジョグは、キーを離したとき、またはウィンドウがフォーカスを失ったときに止まります。

ツール > 設定… > パネルとデバイス > 手動パルス発生器(ハンドル) で、ハンドルの動作を設定します。速度 は、ホイールが止まると軸も止まります。経路 は、すべての目盛りを移動します。

アラームと対処

アラームが発生すると、機械バーの状態表示が赤になり、バーには次の内容が表示されます。

  • アラームとその意味。例:ALARM:17 モータードライバが異常を報告しています
  • 次の手順: 今すべきことと、それを実行するキー
  • 全手順(手順が複数ある場合)

そのキーをクリックするか、機械 > 次の手順を実行 を使うと、次の手順を実行します。各手順の後、Studio は機械の状態から手順を計算し直します。

アラームのその他の表示:位置が信頼できなくなったときに 位置 の下に表示される行、リストでプログラムが停止した箇所の赤い行、3Dビューのドライバに付くラベル。

アラームの種類、原因、解除方法:アラーム。

作業に戻る手順

全手順 を押すと、作業に戻る手順が開きます。原因、続いて順番に並んだ手順があり、各手順には、そのキーと、その手順が必要な理由が付いています。今実行する手順にはマークが付きます。1回のクリックで実行されるのは、次の手順だけです。

たとえば、ドライバのアラーム(ALARM:17)の後は、次のようになります。

  1. 非常停止を押してドライバの電源を切る(F1):ドライバのアラームは、ドライバの電源が切れたときにしか解除されません。
  2. 非常停止を解除(F1)。
  3. 電源投入(F2):ドライバに再び電源が入ります。
  4. リセット(F12):ドライバが復帰した後も、コントローラは ALARM:17 を保持しています。
  5. 原点復帰(F3):電源が切れていたため、位置は信頼できません。

故障が 診断 で注入されたものである場合は、原因にそのことが時刻とともに表示されます。

アラームでプログラムが停止した場合は、手順の最後に、そこから再開するブロックが示されます。たとえば、停止したレイヤーの先頭です。

ブロックからの再開

Studio は、プログラムを任意のブロックから開始できます。そのブロックの時点でプログラムが機械に設定しているはずの状態に機械を整える開始ブロックを書き出し、続いて残りを実行します。

  1. プログラムを停止します。機械の電源が入っていて、プログラムが実行中でない必要があります。
  2. ドックの プログラム タブで、そのブロックを右クリックして ブロック … から開始 を選び、OK を押します。エディタでは、行のマージンを右クリックするか、Shift+F10 を押します。結果:Studio が「name(ブロック n から)」を読み込みます。開始はしません。
  3. サイクルスタート を押します。

開始ブロックは、次の動作を行います。

  1. Z を上端まで上げる
  2. そのブロックの時点でプログラムが設定していた単位、平面、距離モード、ワーク座標系を設定する
  3. そのブロックより前にプログラムが工具を交換していた場合は、工具を交換する
  4. クーラントと主軸をプログラムの回転数でオンにし、主軸が回転数に達するまで待つ
  5. 安全な高さで開始点の上へ移動し、その 2 mm 上まで下降してから、送りで下降する
  6. そのブロックからプログラムを続ける

その後、プレビュー検査が、残りの部分を現在のワークに対して検査します。

注意

開始位置より前のブロックには、Studio が追跡できないものがあります:パラメータ、式、サブプログラム、G10、G28、G30、G92。読み込み時の注記にそれらが一覧表示されます。サイクルスタート を押す前に、機械の状態を確認してください。

先にコピーで開始部分を試す

アラームでプログラムが停止した後は、手順の最後に 開始部分をプレビュー… が表示されます。これを押すと、開始ブロックとその注記が開きます。

  1. コピーで試す をクリックします。結果:開始部分が、現在のワークを使って機械の非表示コピー上で実行され、Studio が、所要時間、衝突(あれば)、最大のびびり指標、除去量を報告します。
  2. 問題なさそうであれば、作業に戻る手順を実行してから、そのブロックから開始します。

シミュレーション速度での実行

ツインは実時間で動作します。シミュレーション > 速度 を使うと、実時間の 0.5倍から 50倍まで変更できます。機械バーの時計には、シミュレーションの時間、選んだ倍速、コンピューターが実際に達している倍速が表示されます。

シミュレーション > シミュレーションを一時停止、または機械バーの砂時計で、ツインの時間が止まります。止まっている間は、何も変化しません。サイクルスタート で続行します。エディタのブレークポイントと一時停止条件も、同じようにツインの時間を止めます(プログラムとエディタを参照)。

シミュレーションの一時停止は、フィードホールドではありません。機械の状態は凍結されるだけで、停止するわけではありません。