これは以前のバージョン、Studio 1.1.0 のマニュアルです。 最新バージョンのマニュアル

ドキュメント 1.1.0 ユーザーマニュアル

プレビュー:このページの安全上の注意は、まだネイティブの校閲を受けていません。

キーボードとアクセシビリティ

機械、メニュー、パネルのボタン、エディタは、すべてキーボードで操作できます。3Dビューの回転とズーム、3Dビュー内の点の選択、パネルのサイズ変更にはマウスが必要です。Windows では、スクリーンリーダーがパネルのボタンと表示値を読み上げます。

ヘルプ > キーボードショートカット(または ?)に、Studio のすべてのキーが一覧されます。

機械のキー

キー動作
F1非常停止:押して作動、もう一度押して解除
F2電源投入
F3原点復帰
F4ロック解除
F5サイクルスタート
F6 または Spaceフィードホールド
F7停止:フィードホールドし、機械が止まったらリセット。もう一度押すと、すぐにリセット
F8冷却 のオン・オフ
F9主軸正転
F10主軸逆転
F11主軸停止
F12 または Ctrl+Xリセット

ジョグとハンドル:

キー動作
← →X をジョグ
↓ ↑Y をジョグ
Page Down、Page UpZ をジョグ
Shift とこれらのいずれかキーを押している間ジョグ
1–5ステップを 0.01、0.1、1、10、50 mm のいずれかにする
6押している間ジョグ:すべてのジョグキーが、押している間ジョグする
Ctrl+1〜Ctrl+4ジョグ速度を 100、300、1500、3000 mm/min のいずれかにする
Escジョグ停止
X、Y、Zハンドルの軸を選ぶ
, と .ハンドルを 1クリック分下げる、または上げる(Shift で 10クリック分)

オーバーライド:

キー動作
Ctrl+↑、Ctrl+↓送り +10 %、−10 %
Ctrl+→、Ctrl+←主軸 +10 %、−10 %
Ctrl+0送りと主軸を 100 % に戻す

ジョグキーを 1回押すごとに、1ステップ動きます。押し続けるジョグは、キーを離すか、ウィンドウがフォーカスを失うと止まります。インチでは、ステップは 0.0005〜2 in、速度は 4〜120 in/min です。

F キーは、どこにいても使えます。ほかの機械のキーは、テキストボックス、リスト、エディタに入力している間は働きません。3Dビューをクリックすると、キーの操作が機械に戻ります。

数字キー、および , と . のキーは、キーボード上の位置で働くため、どのキー配列でも使えます。

非常停止

F1 を押すか、機械バーの右端にある丸い赤いボタンをクリックします。ツインでは、機械のボタンと同じように、非常停止回路が開きます。軸のドライバと主軸インバータの電源が切れ、コントローラが ALARM:10 を発生させます。もう一度 F1 を押すと解除されます。その後、手順に従って作業に戻ります:電源投入、リセット、原点復帰。

⚠ 警告

F1 と赤いボタンが止めるのはツインです。実機の非常停止ではありません。実機では、機械自体の非常停止ボタンを使ってください。

ウィンドウのキー

キー動作
Alt+1〜Alt+6準備、CAM、プログラム、実行、分析、診断 のいずれかへ移動
Ctrl+Tab、Ctrl+Shift+Tab次または前のワークスペース
Ctrl+Jドックを折りたたむ、または展開する
Ctrl+Shift+M機械を切り替える
Ctrl+Oプログラムを開く…
Ctrl+Pプログラムを印刷…
Ctrl+,設定…
Ctrl+L監査ログ…
Ctrl+Q終了
? または /キーボードショートカット
Alt とメニューの文字そのメニューを開く。Alt だけを押すと、メニュー名が強調表示される
Tab、Shift+Tabパネルのボタン間を移動する。Space で、枠の付いたボタンを押す
Escポップアップまたはサブウィンドウを閉じる

補足

F1 はヘルプではなく、非常停止です。マニュアルを開くには、ヘルプ > ドキュメント か、パネルの ? ボタンを使います。

プログラム ワークスペースのエディタには、専用のキーがあります。

キー動作
Ctrl+Eエディタに移動し、機械に戻る
Ctrl+K読み込んで検査
Ctrl+Sバージョン保存
Ctrl+Shift+Sプログラムをファイルとして保存
Ctrl+D保存したバージョンとの 比較
Ctrl+F、Ctrl+G、Ctrl+H検索、行へ移動、置換
Ctrl+Bその行の ブレークポイント
Ctrl+Shift+B条件で一時停止
Ctrl+.その行に対する検査の提案を適用
Alt+↓、Alt+↑次または前の検出事項、または差分
Shift+F10 またはメニューキーその行のメニュー
Ctrl+Shift+O最適化
Ctrl+Shift+G生成…
Ctrl+Shift+R機械にあるプログラムを取り込む
Esc比較を閉じる

マニュアルのウィンドウでは、Ctrl+F で検索、Alt+← と Alt+→ で戻る・進む、Esc で閉じます。

準備 でワークを配置している間は、矢印キーで移動し(Shift で細かく、Ctrl で粗く)、Q と E で回転し、Enter で配置し、Esc で元に戻します。

キーの完全な一覧

ヘルプ > キーボードショートカット には、上記のすべてのキーが 1つの一覧で表示されます。次のコマンドにはキーがありません。それぞれのメニューを使ってください。

  • シングルブロック と 次のブロック(プログラム メニューと機械バー)
  • プログラムを検査
  • 軸のゼロ設定とゼロ位置への移動(機械 > ワーク原点)
  • ツールセッターとプローブの動作(機械 > ツールセッターとプローブ)
  • 1000 min⁻¹ ずつの主軸回転数の変更と、早送りオーバーライド(機械)
  • シミュレーションの一時停止と速度(シミュレーション)

スクリーンリーダーを使う

Windows では、Studio は、システムのアクセシビリティインターフェースを通じてスクリーンリーダーと連携します。Studio の各パネルで、スクリーンリーダーは次の情報を受け取ります。

  • 各ボタンの名前、ボタンの種類、オン・開いている・使用不可のどれか、ショートカット、ヒント
  • 表示値のテキスト:機械バー(状態、プログラム、進捗、次の手順、時計)、トップバー(機械、状態、AI、レベル、エディション)、右の列(位置、主軸、ゲージ、モーダル行)
  • Tab によるフォーカスの移動のひとつひとつ
  • メニュー:各項目の文言、ショートカット、使用不可かチェック済みか、現在どの項目にいるか

フォーカスがどこにあっても、次の 2つは、発生した時点で通知されます。アラーム(次の手順を含む)と、AI による機械の変更の要求です。

マニュアルのウィンドウでは、ページのテキストが、見出しとリンクを含めてスクリーンリーダーに渡されます。

1.0 では次のとおりです。

  • 機械の状態のその他の変化は、通知されません。聞くには、フォーカスを機械バーに移します。
  • プログラムリスト、コンソール、メッセージ、エディタ、工具テーブルは、スクリーンリーダー自身の規則で読み上げられます。曲線は読み上げられません。
  • Linux では、スクリーンリーダーはサポートされていません。

3Dビューで読み上げられるもの

3Dビュー自体は、スクリーンリーダーに何も渡しません。3Dビューに表示される数値は、右の列と機械バーにあり、そちらはスクリーンリーダーが読み上げます。ワークの点をクリックすると、ビューの下の文(プログラムの行と位置)が読み上げられます。

大きな文字と工場モード

Studio は、Windows で画面ごとに設定した表示スケールに従います。Studio 独自の文字サイズ設定はありません。

表示 > 外観 > 工場モード(大) を選ぶと、機械バー、そのボタン、非常停止、文字、プログラムリスト、位置表示が大きくなり、実行 ワークスペースには、腕を伸ばした距離から読むためのレイアウトが適用されます(ライト、ダーク、工場モードを参照)。

システムのアニメーションがオフになっている場合、3Dビューは、滑らかに移動する代わりに、新しいビューへ瞬時に切り替わります。