これは以前のバージョン、Studio 1.0.2 のマニュアルです。 最新バージョンのマニュアル

ドキュメント 1.0.2 運用ガイド

システム要件

Twinwright Studio を動かすためにコンピューターに必要なものと、3Dビューがグラフィックスに求めるものを説明します。

Windows

  • 64 ビット版の Windows 10 または Windows 11(x64)。これ以外のバージョンでは、インストーラーが停止します。
  • ほかにインストールするものはありません。Studio は 1つの実行ファイルで、Windows に付属するライブラリだけを使います。

Linux

  • x86-64 の Linux、glibc 2.38 以降:Ubuntu 24.04、Debian 13、Fedora 39 以降、およびそれらをもとにしたディストリビューション。
  • X11 または Wayland のデスクトップ。
  • AppImage には FUSE 2(Ubuntu では libfuse2t64 パッケージ)。ない場合は .tar.gz を使います。
  • オンラインでの有効化と試用:libcurl(Ubuntu では libcurl4t64 パッケージ。デスクトップには通常入っています)。ない場合、Studio はオフラインで有効化します。
  • AI サービスのキーには、デスクトップのキーリング(Secret Service:GNOME Keyring または KWallet)。ない場合、Studio はキーをあなただけが読めるファイルに保存します。

グラフィックス

3Dビューは Direct3D 11 を使います。Direct3D 11 に対応していれば、グラフィックスカードでも内蔵グラフィックスでも使えます(機能レベル 10.0 以上)。対応するものがない場合、Studio は Windows のソフトウェアレンダラー(WARP)で描画します。動作はしますが、ビューが遅くなり(最大で毎秒 30 フレーム)、工具のクローズアップはありません。

ヘルプ > バージョン情報 の ディスプレイ に、Studio がどちらを使っているかが表示されます。

3Dビューが起動しない場合

3Dビューがなくても、ウィンドウのそれ以外の部分は動作します。ビューが空のままのとき、または使用できないと表示されるときは、次のようにします。

  1. ツール > 設定… > ファイル を開きます。
  2. ソフトウェアレンダリング(グラフィックスカードに問題がある場合。次回起動時に反映) にチェックを入れます。
  3. Studio を閉じて、もう一度起動します。

グラフィックスカードのドライバを更新すると、原因が解消することがよくあります。

Linux

Linux では、3D ビューは OpenGL 4.1 以上を使います。過去 10 年のグラフィックスなら Mesa ドライバーにあります。グラフィックスドライバーがない場合は、Mesa のソフトウェアレンダラーが(遅くなりますが)ビューを描きます。試すには、端末からプログラム名の前に LIBGL_ALWAYS_SOFTWARE=1 を付けて Studio を起動します。

メモリとディスク

  • メモリ:8 GB 以上。
  • ディスク:Studio 本体とマニュアルに約 62 MB、それに加えてデータ用の空き容量が必要です。データは使うほど増えます。監査ログは、既定で 180日間、最大 2 GB まで保持され(ツール > 設定… > ログ)、プログラムの全バージョンとレポートはすべて保持されます(データとバックアップを参照)。

画面とスケーリング

  • 1280 × 720 以上。Studio のレイアウトは 1600 × 1000 以上を想定しています。
  • 表示スケールは任意です。Studio は画面ごとのスケールに従い、ウィンドウを別の画面に移すと、その画面のスケールに合わせ直されます。

実機

1.0 では、実機への接続はプレビュー機能で、コマンドラインから行います(実機を参照)。接続できるのは、115 200 ボーのシリアルポート(USB)か、ネットワーク上のコントローラです。

Studio がネットワークを使うのは、次の場合です。

  • G コード送信ソフトは、このコンピューター上のツインにポート 2323 で接続します。
  • ブラウザビューは、このコンピューター上のポート 8765 を使います。
  • アドレスを受け付ける AIクライアントは、オンにしたとき、このコンピューター上のポート 8766 を使います。
  • オンラインのアクティベートと更新は、ライセンスサーバーに接続します。

Studio のポートは、このコンピューターだけで待ち受けます。ほかのコンピューターからは接続できません。

Linux では、シリアルポートは dialout グループのものです。一度だけアカウントを追加し(sudo usermod -aG dialout $USER)、ログインし直してください。