ドキュメント ユーザーマニュアル
分析と診断
分析 は、実行を振り返ります。時間がどこで使われたか、切削抵抗とびびりに関するツインの推定値、そして加工した部品と設計との比較がわかります。診断 は、機械の電源系統と信号を表示し、ツインに故障を注入して、その原因を見つける練習ができるようにします。
実行を振り返る
分析(Alt+5、エンジニアレベル以上)は、プログラムが実行されると内容が表示されます。
- 左の 実行履歴 には、このセッションの実行が一覧表示されます。プログラム、終了の仕方、機械時間、開始時刻です。アラームまたはエラーで終了した実行は赤で表示されます。
- 中央にグラフがあり、その下に ブロック別プロファイル と 安定限界線図 の 2つのタブがあります。
- 右の 前回の実行 には、前回の実行の要約が表示されます。どこまで進んだか、最も時間のかかったブロック、最大切削抵抗と最大のびびり指標、およびそれぞれのブロック、除去量、送りに達しなかったブロック、イベントです。
グラフ、プロファイル、要約は、前回の実行のものです。
ブロック別プロファイル には、時間のかかったブロックが、長い順に並びます。時間とその割合、指令された送りと実際に達した送り、達しなかった理由、切削抵抗、びびり指標、除去量、イベントが表示されます。ブロックをダブルクリックするか、Enter を押すと、プログラム エディタのそのブロックへ移動します。
ブロックが送りに達しなかった理由は、次のとおりです。
- 軸の最高速度
- コーナー同士が近すぎて、その間で加速しきれない
- 円弧の弦による制限
- コントローラのプランニング、送信ソフトの遅れ、またはコントローラの読み取りの遅れ
- 100 % 未満の送りオーバーライド、またはフィードホールド
時間:推定値と実際の値
実行前に、Studio はプログラムの送りと早送りから機械時間を推定します。機械バーにはその時間が 約 を付けて表示され、ドックの プログラム構造 にはセクションごとの時間が表示されます。実行中と実行後の時間は、加速度とコントローラのプランニングを含む、ツインの機械時間です。機械バーには経過時間と残り時間が、プログラム構造 には実行全体の時間が、ブロック別プロファイル には各ブロックの時間が表示されます。
すべての時間は、シミュレーション内の機械時間であり、実際の時計の時間ではありません。
切削抵抗、びびり、切りくず厚さ
グラフには、直近 10、30、または 120 s の実行中の値が表示されます。送り、実速度、主軸の回転数と負荷、切削抵抗、トルク、パワー、切りくず厚さ、びびり指標、追従誤差です。グラフ名をクリックすると、表示と非表示が切り替わります。
びびり指標は、切込み深さを、使用中の主軸回転数で安定な深さで割った値です。
| 指標 | 意味 |
|---|---|
| 0.8 未満 | 安定 |
| 0.8–1 | 限界付近 |
| 1 を超える | びびり発生 |
安定限界線図 は、直前の切削について(まだ切削がない場合は、X 方向の深さ 1 mm のフルスロットについて)、主軸回転数に対する安定な切込み深さを描きます。安定限界線図を計算 をクリックします。赤い点は実際の切削条件を、緑の破線は最も安定な回転数を示します。
表示 > 色分け で、工具先端の軌跡を、送り速度、切削抵抗、切りくず厚さ、びびり指標、プログラムのブロックで色分けできます。ワークは、材料と深さ、部品との偏差、プログラムのブロックで色分けできます。
これらは、物理モデルに基づくツインの推定値です(ツインのモデルを参照)。
設計形状との比較
加工した部品が設計とどこで異なるかを確認するには、次のようにします。
- 準備 の 段取り ステップで、部品STL(比較用)… をクリックし、部品の STL ファイルを選びます(単位は mm、原点はプログラムの原点)。
- プログラムを実行します。
- 表示 > 色分け > ワーク:部品との偏差 を選びます。
結果:ワークは、各点が部品からどれだけ離れているかによって色分けされます。±20 µm 以内は良好とみなされ、それ以外の色は削り残しと削り過ぎを示します。比較を終了 で、部品が取り除かれます。サンプル部品を読み込むと、それぞれの部品が読み込まれます。
2回の実行の比較
分析 には前回の実行が表示されます。プログラムの 2回の実行を比較するには、次の方法があります。
- プログラム エディタで 比較(Ctrl+D)を使うと、両方のバージョンがこのセッションで最後まで実行されている場合に、両方のバージョンの実行時間と、変更された行の時間がわかります(2つのバージョンの比較を参照)。
- AIアシスタントは、2回の実行を並べて描画できます(AIアシスタントを参照)。
エクスポート
グラフをエクスポート (CSV)…(前回の実行 内、または ファイル > グラフをエクスポート (CSV)…)は、グラフの直近約 160 s を CSV ファイルとして保存します。時間の列(単位は秒)に続いて、グラフごとに 1列があり、見出しに単位が付き、値は表示単位です。
準備 の ワークをエクスポート…(または ファイル > ワークをエクスポート…)は、加工したワークを STL ファイル(プログラム座標、素材座標、または機械座標)または高さマップとして保存します。
診断ワークスペース
診断(Alt+6、テクニシャンレベル以上)は、機械の電源系統を図で表示します。電力は左から右へ流れます。実線は電力を運び、通電中は緑です。破線は信号です。各部品は、正常なときは緑、オフのときは灰色、警告のときは黄、アラームまたは故障のときは赤で表示されます。
部品をクリックすると、右の列に詳細が表示されます。図の下には、コントローラの入力、故障注入、ドライバアラームがあります。
電源系統
MC-1 の電源系統は、商用電源から主軸まで、次のとおりです。
- 主電源スイッチ QF1 と、コントローラ用の 24 V 電源
- コントローラ:その状態またはアラーム
- 非常停止 SB0 と、それが開放する接触器 KM1
- ドライバ用の 48 V 電源
- X、Y、Z のドライバと各軸
- インバータ、主軸、クーラントポンプ
コントローラの入力
各入力にランプがあります。リミットスイッチ(X− リミット、X+ リミット、Y− リミット、Y+ リミット、Z リミット)、ツールセッター、非常停止、ドライバアラーム です。ランプは、入力がオフのときは灰色、オンのときは黄または赤になります。
ツールセッター のランプは、コントローラのプローブ入力です。タッチプローブが接触したときにも点灯します。
ドライバ
各ドライバには、準備完了 と追従誤差、または 無効、アラーム、起動中、電源オフ が表示されます。詳細には、ドライバの電源と、各軸の追従誤差が、最大値とともに表示されます。
主軸インバータ(VFD)
インバータ には、出力周波数と電流、または異常が表示されます。異常は OC(過電流)、OL(過負荷)、LU(不足電圧)です。詳細には、主軸回転数と指令された回転数、負荷、ポンプが表示されます。クーラントなしで回転した主軸は、その時間とともに、警告に一覧表示されます。
ツインへの故障の注入
故障注入を使うと、ツイン上で故障を見つけて解消する練習ができます。変更されるのはウィンドウ内の機械であり、実機ではありません。
- 配線:機械の任意の配線(リミットスイッチ、ツールセッター、ドライバのアラームチェーン、非常停止線、KM1 の回路、RS485 バス、インバータの故障リレー)を、断線、短絡、間欠断線、瞬断(50 µs の途切れが 1回)のいずれかにします。正常 を選ぶと、配線が元に戻ります。
- ドライバアラーム:X、Y、Z のいずれかを選ぶと、そのドライバが異常を報告します。ドライバのアラームは、ドライバの電源が切れたときにしか解除されません。機械バーの、作業に戻る手順に従ってください。
注入した故障は、警告の下に一覧表示され、コンソールに書き込まれ、監査ログに記録されます。ドライバのアラームの後は、機械バーの原因に、注入した故障とその時刻が表示されます。
アラーム:各アラームと復旧手順
すべてのアラーム、その意味と原因:アラーム。機械バーには、発生しているアラームに応じた、作業に戻る手順が表示されます(作業に戻る手順を参照)。
| アラーム | 作業に戻る手順 |
|---|---|
| ドライバの異常(ドライバがアラーム状態の ALARM:17) | 非常停止を押して解除し、電源投入、リセット、原点復帰 |
| 非常停止が押された(ALARM:10) | 非常停止を解除し、電源投入、リセット、原点復帰 |
| ドライバが復帰した後の ALARM:17 | リセット、原点復帰 |
| 原点復帰が必要(ALARM:11) | 原点復帰 |
| ハードリミット(ALARM:1) | リセット、ロック解除、ジョグでリミットスイッチから脱出、原点復帰 |
| ALARM:3、8、9 | リセット、原点復帰 |
| その他のアラーム | リセット、ロック解除 |